Nachi

From

Jump to: navigation, search

Nachi SC06F-02


Nachi robot.jpg

Documentation

March 26 2014

Been to Filip Jonkers' workplace today, pictures can be found here, and got the first signals of life from the Nachi robot. It started up complaining about a constant file missing, and by placing a 1.44" disk and choosing "format", we were able to initialize the system.

edit: was this formatting the floppy? I don't think so; formatting the floppy from the Teacher Panel took very long, this took quite a short time. The manual says that there's a RAM that stores the setup (backed up by battery), maybe that had to be formatted.

We got a lot of complaints about batteries that were dead, and found one battery in the main cabinet (looked like normal AA, but was in fact 3.6V Lithium cell). Somehow the handheld trainer device still nags about an emergency stop, although all 3 stops are in extended position.

After reading some material at home, we can try the following things:

  • Using the brake release switches at the top of the control cabinet
  • Replace battery, and batteries (type? Also Lithium?) in the base of the robot to take care of backup of system
  • Figure out emergency stops. All signals should be normally closed. The Safety plug feature should only limit speed of operation, not operation itself.

Actions today

  • Floppy1, msdos? 1.44
  • Format floppy (?)
  • Select constant file optie 5 (SC06-F02)

March 28 2014

Filip opened the battery hatch in the base of the robot and found 6 more lithium cells. These batteries seem to be good replacements. Batterijen.jpg


Next time we should bring :

  • Soldering material & Multimeter
  • Serial cable with 25 female to connect to controller.
  • Computer with 3"5 floppy drive and 1.44 Mb floppys (to store programs?)
    • alternative there is a CF Card slot inside the machine, probaly also to store programs.
  • Batteries, Lithium type already ordered by Filip
  • Some pieces of threaded rod, to put robot in callibration position.

April 8 2014

Robot is at the AKI, Ed Frisken is also helping out. Batteries have been replaced. Estop messages were muted by bypassing both emergency stop signals. Had to reset the controller again, as it also had a new battery. Formatting does not need an inserted diskette in the drive. We tried to calibrate the motor axes (manually releasing each axis with the switches in the top of the control cabinet) according to section 6.4.3(?). After poking around a bit on the controller, and trying to get the encoder values at the good levels we were still stuck at an error considering the temperature sensor of one of the motors. One of the multicable connectors pins in the robots' base had been pushed back. Pulled it forward again, but no result.

April 15 2014

Powered on the robot, heard a small bang, nothing. The robot controller was switched on when I entered the power plug, this apparently killed the fuse for the garage door power (used for the robot). The fuses are in a closet in the hallway towards the reception. Rebooting.... Succes! With the batteries, the encoders and the controller has not reset, and the mysterious error on motor temperature also vanished! In teach mode, we were able to program some steps (using the Nachi robot scholing document), although all in the same position, as the robot wouldn't move. When trying to get some movement we got an error about the magnetic contactor that was not giving the right signal. What contactor? We had heard one click before (like the brakes were released??). My suspicion is that this has to do with the contactor that is in the back of the cabinet, which switches power to the motor controller.

Unknown date

Tryed to reset the home positions several times, system still get errors. Filip Jonkers decided to sell the machine and got one that was already working. To bad

Helpfull links